Free Microsoft Excel 2013 Quick Reference

Change the chart format by clicking Results

im making a pivot chart of some data and i would like the chart to have certain default features namely the lines on the chart i would like to be 'smoothed' and if possible the weight increased by one.

currently im clicking on each line and changing those options

is there a way to default those options so that i dont lose the formatting when i switch a field and so that i dont have to click on each line individually?

thanks in advance!

row

I'm working on an Excel that takes input (10-12k points generally), performs some transform calculations to fit data to a model, then plots the points versus the model curve. Often, when viewing the plot, there is errant data that needs to be removed. The old method involved finding the points that caused the bad points, removing them from the dataset, recalculating things and so on. It'd be much nicer if I could graphically select points and remove them that way.

I've overridden chart events and I've made it so that if I click a point, it marks it as an outlier by changing its color to red, clicking changes back. On another sheet, if I click a button it removes the outliers and replots everything. This part works great, no problems.

This is can be a very slow process since there can be lots of points that are outliers. I've implemented a sort of rectangular select to help that. Basically the user holds down shift and clicks two corners. Given that box, the macro goes point by point and checks to see if a datapoint exists there and then marks it for deletion. This has two problems:

1) If there are multiple datapoints at the same gui coordinates, only the top most one gets marked.

2) It is extremely slow.

(2) is more of a priority, but if you have any advice on (1) that'd be great also. I've optimized this code (which runs in the chart mouseup event) as much as I can, but it can still be very slow if the bounding box is small.

The code in question is below with my comments, any help would be greatly appreciated.

Thanks!

(sorry, I'm running Excel 2007 and I can't get the formatting addin to load)

Code:
Private Sub Chart_MouseUp(ByVal Button As Long, ByVal Shift As Long, ByVal x As Long, ByVal y As Long)

Dim ElementID As Long, Arg1 As Long, Arg2 As Long
Dim curX As Variant, curY As Double
Dim newcolor As Integer

'Disable screen redrawing to improve time
Application.ScreenUpdating = False

'If the user is hold the shift key when click
If Shift = 1 Then

    'Mark the boxing procedure as started
    bLineClicked = False
    bBoxClicked = Not bBoxClicked

    'For the first click just store the coordinates
    If bBoxClicked Then
        lFirstX = x
        lFirstY = y
    Else    'After the second click, determine the box and process
        With ActiveChart
        
        'Determine the left-to-right and top-to-bottom bounds of the box
        xStart = Minimum(lFirstX, x)
        xEnd = Maximum(lFirstX, x)
        yStart = Minimum(lFirstY, y)
        yEnd = Maximum(lFirstY, y)
                
        'For every point in the box
        For ix = xStart To xEnd
        Application.StatusBar = ((ix - xStart) * (yEnd - yStart)) / ((xEnd - xStart) * (yEnd - yStart))
        
            For iy = yStart To yEnd
                'Check to see which element is below the ix,iy coordinate
                .GetChartElement ix, iy, ElementID, Arg1, Arg2
                
                'If it is a plot point in series 1
                If ElementID = xlSeries And Arg1 = 1 Then
                
                    'Determine what the points new color should be (red=outlier, blue=ok)
                    newcolor = nBadColor
                    If .SeriesCollection(Arg1).Points(Arg2).MarkerBackgroundColorIndex = nBadColor Then
                        newcolor = nOKColor
                    End If
                    
                    'Assign the point color
                    .SeriesCollection(Arg1).Points(Arg2).MarkerBackgroundColorIndex = newcolor
                    .SeriesCollection(Arg1).Points(Arg2).MarkerForegroundColorIndex = newcolor
                End If
                
            Next
        Next
        
        End With
    End If
        
End If

Application.ScreenUpdating = True
Application.StatusBar = False

End Sub


Von Pookie's HTML Maker FAQ
Last updated: 07 July 2009

07 July 2009: Downloads are currently unavailable for Colo's site. If you would be interested in testing the new HTML Maker designed specifically for the MrExcel forum, please see this thread:
http://www.mrexcel.com/forum/showthread.php?t=399380

PLEASE NOTE: This FAQ was written while we were using phpbb forum software. I have not checked these instructions for accuracy with the new vBulletin software we are currently using. It is possible that some items listed here may no longer apply.

Please note the following:
This is not the FAQ for the VBHTML Maker nor the YaBB Table Maker.These directions were written using Windows 2000 and XP, and Excel 2002 and 2003. I do not (currently) know the information for Macs or any other versions of Windows or Excel.

How can I show a small image of my worksheet in my post?
You can simply download the handy HTML Maker add-in! The HTML Maker is available for download at Colo's site. Currently unavailable

I have downloaded the .zip file. What is the next step?
You may need to download an extraction program such as WinZip to open the .zip file and extract the add-in file. For now, just extract the HtmlMaker.xla file to your desktop. Once you have this, you no longer need the .zip file.

Next, you need to locate the Addins folder on your computer. There are several places you may see a folder with this name. From the Excel help file: "Add-ins are stored by default in one of the following places:
The Library folder or one of its subfolders in the Microsoft OfficeOffice folder.The Documents and Settingsuser nameApplication DataMicrosoftAddIns folder."If you're uncertain which folder to use, open Excel, go to the Tools menu and select Add-ins. In the dialog that will display, click the Browse button to see the path for the AddIns folder it is using. Once you've located this, you can simply drag and drop the HtmlMaker.xla file into it.

Note: If you cannot find the Application Data folder, you probably just need to change a setting on your computer.Open Windows Explorer (or any folder) and select Folder Options from the Tools menu.On the View tab, look for "Hidden files and folders" under the Advanced SettingsMake sure the option "Show hidden files and folders" is selected, click OK, and look for that pesky Application Data folder again.

I have added the file to the AddIns folder, but I am unable to activate it in Excel!
Start Excel, go to the Tools menu and select Add-Ins. You should see a dialog box with a list of available add-ins, with a checkbox next to each item. Simply find the one labeled Htmlmaker, check the box next to it and click OK. You should now have a new menu between the Window and Help menus called HTML. You have now installed and activated the HTML Maker, and should be ready to go!

How do I use this add-in?
Using the HTML Maker to post a "snapshot" of your worksheet on the message board is relatively simple.
[list=1][*]Make sure you have enabled HTML in your board profile.Click the "profile" link--which is in the group of text links at the top-right of every page of the board.In the list of preferences, make sure the option for "Always allow HTML" is set to Yes.Click the "Submit" button to save any changes to your profile[*]Make sure the HTML Maker add-in is active (see "I've added the file to the AddIns folder, but I can't figure out how to activate it in Excel!").[*]Go to the HTML menu and select "Convert sheet to HTML"[*]Select the range you want to copy
Please select only the range (preferably with little to no formatting) that is crucial to the question you are asking.[*]Click OK[*]On the message box that pops up, click "yes" (I honestly have no clue what this does, but I always click yes and it works just fine)[*]Another message box will appear, letting you know how many characters the HTML Maker code will use, and how many characters that are remaining for you to use in typing the rest of your message. Click OK.[*]A new browser window will open, displaying what your copied cells will look like when posted to the board.[*]In this new window, click the "Copy code to clipboard" button.
If this does not work...[list=a][*]If you are running Windows XP with Service Pack 2 installed, make sure you allow popups on the page (they will be blocked by default) and try clicking the button again[*]As an alternative:In this same window click the button that is on the page that is labeled "View Source." This is located right next to the "Copy to Clipboard" button.Copy the entire code that is displayed there.[/list:o:4e41f3da2f][*]Come back to the board where you are entering your message, and put your cursor in the area where you type the body of your message.[*]Press Ctrl+V in the area where you type. If you don't know HTML, it will look like a lot of gibberish. That's normal, don't worry about it. You can still edit and add to your message if needed at this point. Do not edit/add to the code from the HTML Maker.[*]When you are finished, click the Submit button to post your message. The table should appear in your post just as it did on the browser page you copied the code from.
Do not preview a message containing HTML Maker code. You will not be able to use the buttons on the preview page to submit your message.Do not quote a post using HTML Maker code. You will receive errors (when quoting a message, simply edit out any extra HTML Maker code).[/list:o:4e41f3da2f]Back to top

Known Issues & Errors

I installed the HTML Maker add-in, but the "HTML" menu you say should appear on the menu bar is not there.
It is possible that you have installed the wrong add-in. This FAQ is for Colo's HTML Maker, NOT the VB HTML Maker or YaBB Table Maker. Making sure you have installed the correct add-in is the first step.

If you have confirmed that you installed Colo's HTML Maker correctly, make sure you have enabled the add-in. Go to ToolsAdd-Ins, click the checkbox for the HTML Maker and click OK. The menu should then appear.

If you have performed both of the previous steps and the menu is still not appearing, post your questions in the Questions About This Board forum.

I followed the directions, but after posting the page is not displaying correctly.
You can either edit the post yourself and remove ALL of the HTML code, or report the post by clicking the "Report" button () on the post to notify the moderators of the problem. A moderator will edit the post to remove any/all HTML Maker code so the thread will be able to display correctly.

As to why the page displayed strangely in the first place, it's usually one of two things: either you didn't follow the directions and copied the source of the page the HTML Maker generated instead of using the "view source" button on the page (yes, there is a difference and we can tell from the code if this is the case), or you have inadvertently posted incomplete HTML Maker code--which is much more common.

HTML requires both opening and closing tags; if you do not post the entire code, the closing tags are not included and the board cannot interpret the code correctly.

When using an HTML Maker example in your post make sure that you have copied all of the generated code and that it is pasted into the message in its entirety. There is also a character limit for each message (but to be completely honest, I have no idea what that limit actually *is*). If you try to use multiple examples within a single post, you can hit the limit quickly and the end of the code could be cutoff.

Error: "Could not load an object because it is not available on this machine"
You may be missing a file called ietimer.ocx, which is required. Click here to go to Colo's site and check if the file is already installed on your computer. This link will also automatically install the file for you if it is needed.
The file is also available for download from Microsoft: http://activex.microsoft.com/control...86/ietimer.cab After downloading the file, it must be registered with regsvr32. The easiest way to do this is to right-click the file and select Install from the context menu.

Error: "Compile error." or "Can't find project or library..."
Open the Visual Basic Editor by pressing Alt+F11. Once in the editor, select the HTMLMaker in the Project window then go to the Tools menu and select References.
If there are any references that start with "MISSING," uncheck them and don't forget to save.
More information on this error can be found in this thread: http://www.mrexcel.com/board2/viewtopic.php?t=107231

Error: "Error Number: 91, Object Variable or with Block variable not set..."
Click OK to close the dialog box with the error and go to Tools->Macros->Security. Click the Trusted Sources tab and check the box next to "trust access to Visual Basic Project," and click OK.

In Excel 2007, the directions are slightly different:
Click the Office Button and go to Excel Options->Trust Center->Trust Center Settings->Macro Settings->Developer Macro Settings. Then you can Check the "Trust access to the VBA project object model" box and click OK.
(Thanks to Bradlee_S for posting this, because I would have never thought to add it otherwise)

Error: "Runtime error: 5 Invalid procedure call or argument."
When this error occurs, the following line will be highlighted in the debugger:
Code:
Open the Visual Basic Editor (Alt+F11) and go to Tools->Options. Select the General tab and make sure "Break on unhandled
errors" is selected for "Error Trapping."

First mention of this error (and solution) can be found in this thread:
http://www.mrexcel.com/board2/viewtopic.php?t=242967

I am unable to view formulas after clicking the formula link in the posted example
There are two or more posts in the thread with HTML Maker examples, which could cause a conflict in the Javascript code being used. There is no real "fix" for this issue that I know of. The only real workarounds are to not post a message using the HTML Maker code in a thread already using an example elsewhere, or if you absolutely need to show how the data is set up, use the HTML Maker to show your sheet and indicate what formulas are in what cells within your message. Users viewing the examples in Firefox may notice this problem as well. (I have this issue with Firefox no matter what, personally).

I am unable to copy the generated code to the clipboard.
As was discovered by board member Parry: "If you have installed Windows XP Service Pack 2, a Pop-Up blocker is installed [in Internet Explorer] as part of the pack and by default this will block active content.

When you select your cells and run HTML Maker it will create an HTML page of your image as expected, but the pop-up blocker will prevent you copying the code when you click the button to send Source to the clipboard. Simply click on the pop-up security information bar, then select Allow Blocked Content and you can now copy the HTML to the clipboard."

Back to top

Miscellaneous
[list][*]This add-in is simply to show a small "snapshot" of the selected area of your spreadsheet. However, some things will not display when posting an HTML Maker example, such as:Drawings and objects (i.e., items created from the Drawing toolbar)Clip art and other imagesCharts and graphsConditional formatting[/list:o:4e41f3da2f]Questions concerning the HTML Maker should be posted in the Questions About This Board forum.
If you have not used the HTML Maker add-in before, please post in the Test forum before making your actual post to make sure the example will display correctly. If any posts with HTML maker code end up "breaking" the page (including posts in the Testing forum), they will be edited by a moderator or administrator to remove the problem-causing HTML code from your post or the post itself will be deleted.

Find an error or something I missed?
Click to send me a private message

Ok people yall are not giving this person the specific answers to her question.
I have created a wonderful form which uses the tab feature and the mouse to
click on the drop down boxes, and the mouse to click the check boxes.

You have to turn on the forms feature by clicking view/toolbars and then
clicking forms. This will bring up the form toolbar.

The secret to using tab and having your form remain its professional
intergrety is to use the chart box for your place holders. You have a
feature on the drawing toolbar which allows you to select No Border.

When you create your chart using this feature the borders will be pale
colored, and will not print.

You have to make boxes for the data entry spots which will have to be
formated Tools, Table propertys, cell, is exactly .2 or .3 depending on the
size of your font. This makes the person who happens to hit enter not be
able to "change the spacing".

Ok, the highlighed portion which no one told you will be there if you click
on the AB located on the Forms tool bar. If you data should only be a
certain amount of spaces you will click the AB, then right click and change
the number from unlimited to the exact number of spaces requried for the data.

Such as the date feature does not properly work the way I want it to to I
create my cells using a box for the month, click AB, then right click and
limit to 2 letters, I insert a box for the / and then another AB for the
date limited to 2 letters, another box for / and then i input 06.

You must protect the doucment to have it function as a form, so click tools,
protection, and trust me in the beginning stages of creating forms, use a
single letter or number for your password, however if you know how to give
yourself full priviledges and take them away from everyone else that might
have access to your forms in progress folder you can simply click the lock
icon (it looks like a lock) and once you enter the password one time you
simply keep clicking the lock icon.

If any of you care to email at

SITUATION: I've never used Exel for chart-creation. This question
probably makes that all too obvious.

Using Exel 2002's chart wizard, I was able to generate a time-series
chart which displayed my data. However, on the resulting chart, the Y
Axis displayed the years generically (1-30). I wanted this axis to
display the years specific to the dates involved (e.g. 1920-1947).

I right-clicked on the Y Axis and choose , followed by
the Scale Tab. There I set "Minimum:" to the starting data of my time
series, "Maximum:" to the ending date. All other values were kept the
same. I then clicked OK. The chart was now formated just the way I
wanted it.

However...

PROBLEM: The data plot line on the newly-formated chart is invisible
-- it "disappeared".

QUESTION: How do I get the chart to display **both** the time-series
data on the Y-Axis by date and the resulting data plot?

COMPLAINT: This **really** shouldn't be this
difficult!!!!!!!!!!!!!!!!!!!!!

Thanks,

2privatus

I have been using Excel (XP) to make a text chart for several months. Some of
my text entries are rather lengthy. The past two weeks these lengthy entries
are showing up as pound signs (#########) when I click off the cell. I know
the text will fit in the cell, and the problem isn't solved by making the
cell bigger or using a little bit less text. I have the cells formatted as
"text" and "wrap to fit". I have printed the pages and the printed version
also has pound signs. I just want my text to show up!

Various special charts (floating bars etc.) make use of invisible bars
(bars without border and with no area color). How can I access such
bars to change them back into visible ones? I can have them marked by
clicking on an adjacent bar and using arrow keys to locate the next
item(s), but the mouse cursor only catches the underlying chart area
and I cannot find a key combination to bring up the context dependent
menu nor the "format data series/points" box once the bar is marked. I
have MS Office Excel 2003.

Hi,

I want to transfer some charts (as picture) in excel to a particular
word document (specific page and specific position). The word document
already has some data and lots of pages in it and Im inserting charts
in specific places.

When I used to do the above task for Excel to Power- point then I could
use the, Right click Format picture, of Size (Height, Width) and
Position on Slide (Horizontal, Vertical) in order to place the charts
in powerpoint in the exact position and dimension I want.

But Im not able to see an analogous feature in word where I could
specify the Position (Position on page - Horizontal and Vertical) of
object/chart in Word. When I do right click on a picture in Word, then
size tab has height and width (Good for me), but I dont have any tab
for position. What we do have is a tab called Layout, in which the
"Advanced" button has Absolute position ... to of the column and
Absolute position .... below paragraph. Im not sure whether by using
these 2 properties I will be able to position my chart in the place I
want.

Again, I have not been able to try the above because of 2 reasons:-

a) If I copy paste a chart named as Chart1 in excel to Winword then
what is the name of that object in word? For checking this I recorded a
macro in word where I selected a newly pasted chart from excel and see
that the code it produces is

ActiveDocument.Shapes("Group 1570").Select

Knowin the name of the chart in word seemed important to me, because as
soon as im done pasting, the cursor in word moves to the new line or
rather the chart object is no longer active in word. So, if it is not
active then how do I apply positional and size properties to it?

b) Secondly, Im not sure of the of the exact syntax for applying
positional and size properties. When I record a macro in word where I
change the Height/width/Abs Position Col/ Abs Position Para to 2 inches
then I get lot of recorded code out of which following seemed relevant
to me (I have snipped rest).

Selection.ShapeRange.Height = 144#
Selection.ShapeRange.Width = 144#
Selection.ShapeRange.Left = 180#
Selection.ShapeRange.Top = 126#
Selection.ShapeRange.Left = InchesToPoints(2)
Selection.ShapeRange.Top = InchesToPoints(2)

Im not able to understand as to why the Left and Top (Probably the
positonal parameters for object) is getting recorded twice and that too
in different units (once as 180# and another time as
InchesToPoints(2)).

Also, I want to know one more thing. As I have already mentioned I have
text data in word and I have left enough space so that when a new chart
gets pasted the text data below the chart doesnt get shifted down. For
example, in the below code Im first navigating to the page where I want
to paste chart and then pasting it. In this whats happening is that,
even my page title and rest text gets shifted. How to avoid this
situation

Sub StartTransferProcess(WkbookNam As String, ShtNam As String, ChtNam
As String, _
Pageno As Byte, Height As Double, Width As Double, ColPos As Double,
ParPos As Double)

Set SWinword = GetObject(, "Word.application")
Set Sdocument = SWinword.Documents(WordDocName)

Workbooks(WkbookNam & ".xls").Activate
Sheets(ShtNam).Select
ActiveSheet.ChartObjects(ChtNam).Activate
ActiveChart.ChartArea.Select
ActiveChart.ChartArea.Copy

Sdocument.Activate
Sdocument.ActiveWindow.Selection.GoTo What:=wdGoToPage,
Which:=wdGoToNext, Name:=Pageno
Sdocument.ActiveWindow.Selection.Paste

''' New code to be written for Positioning and sizing object

End Sub

Regards,
HP
India

I saved an XLS file as an XLSX file without performing a conversion. After
making changes to the workbook, the chart names will not save, they just
revery back to the default "Chart1", "Chart2", etc. names.

I followed these steps to change the names to no avail:
When you create charts, Microsoft Office Excel assigns a default name to
each chart by using the following naming convention: Chart1, Chart2, and so
on. However, you can change the name of each chart to make it more meaningful
to you.

Click the chart that you want to rename.
This displays the Chart Tools, adding the Design, Layout, and Format tabs.

On the Layout tab, in the Properties group, click the Chart Name text box.
Tip You may have to click the Properties icon in the Properties group to
expand the group.

Type a new name.
Press ENTER.

Any idea on how to save the names properly?

Thanks,
Brett

Not exactly where to post this but I really need a quick answer....

I am no chart expert by the way! I inserted a line chart that looks against a pivot. I did not like the color choices fro the lines so I clicked the legend and chose others and at different weights. It looks great until I change or refresh the pivot. Then most of my formatting goes bye bye....what gives?

I have been using Excel (XP) to make a text chart for several months. Some of
my text entries are rather lengthy. The past two weeks these lengthy entries
are showing up as pound signs (#########) when I click off the cell. I know
the text will fit in the cell, and the problem isn't solved by making the
cell bigger or using a little bit less text. I have the cells formatted as
"text" and "wrap to fit". I have printed the pages and the printed version
also has pound signs. I just want my text to show up!

I created a couple of charts in Office Excel 2007 Beta 2 and experienced a
few problems. I think this is the proper place to detail them and bring them
to Microsoft's attention (though they may already know).

I created two pie charts by selected the data and titles and clicking the
appropriate ribbon buttons.

I began to modify the first chart by selecting different layouts and 3d/2d
representations. When switching to a 3d chart it stopped updated the look
until I closed and re-opened Excel (at which time my most recent change was
reflected).

I have currency data in one pie chart, and I wanted to display the currency
data and the percentages. I could not get this to happen. At first it display
the percentage data as currency, then when I told it to display the values
too it display the values as general numbers and the percentages as general
numbers, too. I could not get anything entered into the custom field under
Label Formats to be accepted (when I went back to the dialog box it would be
changed back to general format).

Also the charts do not show up in the Print Preview Window, and they
disappear briefly when printing. They do show up in the printed document.

Hey there,

I'm sure i ought to know this but, i cant seem to be able to change the size of the text box my axis labels are in, so lets say i change the font size and then the label text appears on two lines instead of one, i cant do anything about it (clicking the little black squares on the corner of the text box doesnt work ). Nothing for it in the format axis windows.

Its getting me frustrated, is this even possible ? it seems so simple. The only way i managed to do it is either reduce the font size or make the axis longer by changing the size of my chart.

Thanks alot

Have a nice day.

(Im on a PC, windows XP, Office 2003.)

I am having trouble formatting a chart. I have a simple table that
records the no of children attending certain groups we run which is
recorded against the date. The table has been constructed with filters
so that you can click on the names of the different groups and only
numbers for that group are displayed. I created a bar chart from the
table which much to my surprise changed with the filters on the table
this was great.

When not using the filters and looking at all the groups I decided to
colour code each group so that when looking at the bar chart one group
could be compared to the other. I did this by colouring each data point
seperately on the chart.

This worked fine until (and here is the problem I would like help
with.) I selected a filter again the colours applied to the data points
no longer remained with the same data points. i.e if I coloured an
activity yellow and selected a filter on the table for that group all
the chart should be yellow but it is not. I need to be able to keep the
same colours applied to the individual data points no matter what
filters I use

If this message is not clear perhaps I could send the spreadsheet to
anyone you can help to see the problem more clearly. My e-mail is
michael.smith(remove this)@nch.org.uk

Many thanks

Hi,

I want to transfer some charts (as picture) in excel to a particular
word document (specific page and specific position). The word document
already has some data and lots of pages in it and Im inserting charts
in specific places.

When I used to do the above task for Excel to Power- point then I could
use the, Right click Format picture, of Size (Height, Width) and
Position on Slide (Horizontal, Vertical) in order to place the charts
in powerpoint in the exact position and dimension I want.

But Im not able to see an analogous feature in word where I could
specify the Position (Position on page - Horizontal and Vertical) of
object/chart in Word. When I do right click on a picture in Word, then
size tab has height and width (Good for me), but I dont have any tab
for position. What we do have is a tab called Layout, in which the
"Advanced" button has Absolute position ... to of the column and
Absolute position .... below paragraph. Im not sure whether by using
these 2 properties I will be able to position my chart in the place I
want.

Again, I have not been able to try the above because of 2 reasons:-

a) If I copy paste a chart named as Chart1 in excel to Winword then
what is the name of that object in word? For checking this I recorded a
macro in word where I selected a newly pasted chart from excel and see
that the code it produces is

ActiveDocument.Shapes("Group 1570").Select

Knowin the name of the chart in word seemed important to me, because as
soon as im done pasting, the cursor in word moves to the new line or
rather the chart object is no longer active in word. So, if it is not
active then how do I apply positional and size properties to it?

b) Secondly, Im not sure of the of the exact syntax for applying
positional and size properties. When I record a macro in word where I
change the Height/width/Abs Position Col/ Abs Position Para to 2 inches
then I get lot of recorded code out of which following seemed relevant
to me (I have snipped rest).

Selection.ShapeRange.Height = 144#
Selection.ShapeRange.Width = 144#
Selection.ShapeRange.Left = 180#
Selection.ShapeRange.Top = 126#
Selection.ShapeRange.Left = InchesToPoints(2)
Selection.ShapeRange.Top = InchesToPoints(2)

Im not able to understand as to why the Left and Top (Probably the
positonal parameters for object) is getting recorded twice and that too
in different units (once as 180# and another time as
InchesToPoints(2)).

Also, I want to know one more thing. As I have already mentioned I have
text data in word and I have left enough space so that when a new chart
gets pasted the text data below the chart doesnt get shifted down. For
example, in the below code Im first navigating to the page where I want
to paste chart and then pasting it. In this whats happening is that,
even my page title and rest text gets shifted. How to avoid this
situation

Sub StartTransferProcess(WkbookNam As String, ShtNam As String, ChtNam
As String, _
Pageno As Byte, Height As Double, Width As Double, ColPos As Double,
ParPos As Double)

Set SWinword = GetObject(, "Word.application")
Set Sdocument = SWinword.Documents(WordDocName)

Workbooks(WkbookNam & ".xls").Activate
Sheets(ShtNam).Select
ActiveSheet.ChartObjects(ChtNam).Activate
ActiveChart.ChartArea.Select
ActiveChart.ChartArea.Copy

Sdocument.Activate
Sdocument.ActiveWindow.Selection.GoTo What:=wdGoToPage,
Which:=wdGoToNext, Name:=Pageno
Sdocument.ActiveWindow.Selection.Paste

''' New code to be written for Positioning and sizing object

End Sub

Regards,
HP
India

Excel seems to have been primarily designed for accountants but it is also
useful for handling scientific results. Unfortunately the graphing side is
missing a number of important features. It would be useful to know, whether
any of these features are going to be included in the next release of Office.
Is there a feature list available yet?

1) Point and Click Scaling
It is a real pain having to go and type numbers in to change the scale
limits. Often you just want to zoom in on an area. There are several ways
this could be done, either a simple point and click to zoom in; or allow user
to define a rectangular area by dragging out a rectangle with the mouse; or
by placing two cursors on an axis to redefine the end points.
Also when you change the scale on the x-axis, it would be extremely useful
to have an option to autoscale the y-axes, ignoring the data where the x
value is outside the new limits.

2) 3rd and 4th axes
Often you have more than two quantities that you want to display on one XY
chart against the same x-axis. Why does Excel limit the number of y axes to
2? There is enough room for 4 axes by using both sides of each axis line for
the axes labels. Alternatively there is no reason why further y axes couldn't
be added at any arbitrary point on the x-axis, they don't have to be at the
ends.
It would also be nice if the axis colour could optionally be linked to the
series colour (obviously this would only work if the colour for every series
on the axis was the same).

3) Scaling of Date/Time Axis
When you have an axis displaying data formatted as a date or time, and you
choose to alter the scale limits, the values are displayed as a decimal
number rather than in the correct format. You can actually type in a
date/time value, but it is not obvious that you can do this. (same applies to
scientific format data).
Note also that the auto-scaling for the minimum value in logarithmic mode
doesn't work (it always sets it to 1, this is probably just a bug or lazy
programming).

4) Units conversion
I know you can do this with formulae and calculating new columns, but it
would be very nice to have a built in system for specifying what units values
were stored in. It would then be possible to have an option on a chart to
change the units, e.g. from miles per hour to meters per second or days to
minutes, etc...

----------------
This post is a suggestion for Microsoft, and Microsoft responds to the
suggestions with the most votes. To vote for this suggestion, click the "I
Agree" button in the message pane. If you do not see the button, follow this
link to open the suggestion in the Microsoft Web-based Newsreader and then
click "I Agree" in the message pane.

http://www.microsoft.com/office/comm...excel.charting

Various special charts (floating bars etc.) make use of invisible bars
(bars without border and with no area color). How can I access such
bars to change them back into visible ones? I can have them marked by
clicking on an adjacent bar and using arrow keys to locate the next
item(s), but the mouse cursor only catches the underlying chart area
and I cannot find a key combination to bring up the context dependent
menu nor the "format data series/points" box once the bar is marked. I
have MS Office Excel 2003.

I have an Excel chart that has an X axis like this:

Jan-09
Feb-09
...
Nov-09

When I paste this into a PowerPoint presentation, looks great.

When I save and reopen the presentation, the dates have been replaced with:

Dec-04
Jan-05
...
Oct-05

If I right click on the chart and click 'Edit Data" the dates immediately revert back to being correct.

But I have no idea where it's getting those 2004-2005 dates from. They don't appear anywhere either in the presentation or the orginal Excel workbook.

The only other thing I can see that is a bit unusual is that in the Excel Workbook, the axis is formatted as "Text Axis" and in PowerPoint it comes through as "Automatically Select based on data." That said, even after I changed it to Text Axis, the problem persists.

It repeats every time. If I click "Edit Data" it fixes it. Then I save. Then I exit and go back in... broke again.

I'm going to try creating the whole thing from scratch (the chart is rather small) and see if that fixes it... but even if it does I still wonder how this is even possible and where those dates are coming from.

I am as stumped as I've ever been by this.

i have one table of data formatted as a table.

when i click on a cell in the table and insert > pivot chart, and place that chart / table on an existing worksheet, the chart is linked to a different pivot table (not the new one that was just created)...

I have a sheet that contains the pivot tables for about 10 charts on various other worksheets.

i am using a template as a default chart.

everything worked fine until now, but now, when i try to create a chart the same way i had been (by clicking any cell in the table, and selecting "insert" "pivot chart") a new chart and table are created, but the chart is linked to "PivotTable1", and the new table, which usually corresponds to the new chart, is "PivotTable12" or something... If i click on the chart and change the pivot data, it alters the results in "PivotTable1", thus altering the chart which is already linked to that table.

somehow, when i try to create a new pivot chart, i get a new chart and table, but the chart is not linked to the new table...

hope this makes sense...

thanks for the help,

Phil

I'm not sure but my problem might be similar to the one linked below.
However, I can't access the excel sheet (using excel 2003) which makes it difficult to relate to the solution.
http://www.excelforum.com/excel-char...wn-window.html

My problem:
I have data formatted by month for various departments and each department has 3 budgeting categories.
See attached excel.
Basically, if anyone clicks the drop down and selects a month, the chart's data source will need to dynamically change to include only that month's data.

I'm comfortable using formulas or VB, which ever may be more efficient.

Create chart from data source based on dropdown criteria.xls


No luck finding an answer? You could always try Google.