Free Microsoft Excel 2013 Quick Reference

excel graphs line correctly, shows wrong value label?

I have a graph that is graphing the line in relation to the values on the x &
y axis correctly but its showing a value label that is totally wrong??? I
clicked on the line and checked where the line is refrencing its info from
and its from the correct boxes on my excel sheet, when I hold my mouse curser
over the plotted point at issue it says Value:58% which would be correct? HOw
do I make it display the correct value without always having to type it in by
hand (this is a template for many projects)?????????????? The other thing is
all the other posted values are correct on all lines until this last data set
(ie. there are 4 colums refrenced for the graph, with each graphing 3 rows of
info.... its the last row of info that is having the labeling problem... and
only for a couple of the columns, some of them are labeled correctly for this
last row of info)???? This is difficult to explain in words.


Post your answer or comment

comments powered by Disqus
I have a graph that is graphing the line in relation to the values on the x &
y axis correctly but its showing a value label that is totally wrong??? I
clicked on the line and checked where the line is refrencing its info from
and its from the correct boxes on my excel sheet, when I hold my mouse curser
over the plotted point at issue it says Value:58% which would be correct? HOw
do I make it display the correct value without always having to type it in by
hand (this is a template for many projects)?????????????? The other thing is
all the other posted values are correct on all lines until this last data set
(ie. there are 4 colums refrenced for the graph, with each graphing 3 rows of
info.... its the last row of info that is having the labeling problem... and
only for a couple of the columns, some of them are labeled correctly for this
last row of info)???? This is difficult to explain in words.

I am trying to create a simple line chart. One of the series is all zero values. When I add it to the chart it doesn't show unless I have markers turned on. I don't want to have markers. I just want a line to show up and run across the horizontal axis. Is there someway to turn off this new default setting??

-thanks
-eric

Greetings All:
Looking to have a message box that will 'advise' salesmen of their next available Quotation Number, prior to it being entered on the contract, for file naming purposes.

Currently have a custom menu item that gets selected by salesman, from which they can select a heading for page # 1 of contract. It then gives them a reminder message to save the file right away with a new name. I am hoping to include the showing of the Quotation Number in this macro, so it can be included in the new file name.

Basic idea is simple, I think, but can't get it to work. Doesn't matter how I set up my 'statement' I get an error message. Current layout comes up with Compile Error: Syntax Error (which, even after a lot of reading, is greek to me).

Sub NextNumber()

    Dim Msg As String, Title As String
    Dim Config As Integer, ans As Integer
    Msg = "  THE NEXT AVAILABLE QUOTE NUMBER  IS:"
    Msg = Msg & vbNewLine & vbNewLine
    Msg = Msg & vbNewLine & vbNewLine

'   The following line should show the value of the cell in QCNUM, Sheet 2, Cell G4

    Msg = "(C:Excel Add_InsQCNUM.xls("Sheet2").Range("G4").Value"
    
    Msg = Msg & vbNewLine & vbNewLine
    Msg = Msg & vbNewLine & vbNewLine

    Config = vbOKOnly

End Sub


Hi all,

For the last two days I've been searching all around the internet for a solution but no lock.

What I have is the following:

A spreadsheet with all the days of 2007 in one column, in the next the amount of products sold on that day

What I want is:
A graph with a graph line which changes based upon the month's data. For example, the line / scatter points in January would be red, in February blue, etc. I've tried using multiple series but can't get it right.

I really hope someone comes up with an answer because I'm getting desperate

Thanks in advance!

I have a scatter-point chart and I have been able to plot the linear
trendline through those scatter points. I then formatted the linear
trendline and got the equation for the line.

However, I noticed that the y-intercept (7.9...) of the actual line that was
graphed by Excel is not the same as the y-intercept (8.9573) for the equation
that Excel derived from the graphed line. The actual Excel graphed line and
the line the equation appear to be parallel to each other. As a result,
entering data into the equation supposedly derived from the graphed line will
not result in the line that was graphed by Excel.

Thank you in advance for your help

The info that is being graphed is 5 columns wide and 4 rows each (row 1 is a
label). For all 5 columns- rows 2 & 3 there are no issues. For 4 out of 5
columns- row 4, the graph represents the values correctly, but displays the
wrong value.

I have a graph that is graphing the line in relation to the values on the x &
y axis correctly but its showing a value label that is totally wrong??? I
clicked on the line and checked where the line is refrencing its info from
and its from the correct boxes on my excel sheet, when I hold my mouse curser
over the plotted point at issue it says Value:58% which would be correct
except the label shows 25%? HOw do I make it display the correct value
without always having to type it in by hand (this is a template for many
projects)??????????????

I would lie to show the value of only the last point of all series in a line
chart in excel.
I can do it manually, (click the point in the graph - data labels - show
value).
Is it possible to do it automatically, so when I change the data source, the
chart will still show the value of the last point ?

Hello All,
I am using Excel 2007 and have a situation with the charting functionality. For example - I am trying to set up automatic update chart update for Jan 08 – Dec 08 data i.e. user just enters data each month and the graph trend shows up each month. I have done this a lot of times but seem to have a unique situation with excel 07 this time when I am using the line chart type to show the trend.
The date cells that have some kind of formulas used i.e. if function or Iserror function etc. I tried to test the chart by entering data for January it works fine with bar graph only displaying Jan 08 data and other months zero but when I switch the chart type to line chart instead of just showing a point for January 08 data it shows the Jan 08 data and other months as zero i.e. graph line drops from the value to zero.
I tried to set the hidden empty cells as zero and gaps (Excel 07 option) but it did not work. Next I removed the formulas i.e. the IF function and other functions and manually entered the data……line chart worked fine i.e. did not display the subsequent month’s data i.e. Feb 08 – Dec 08 which is all zero.
This to me is weird that once you remove the formulas the line chart works fine by not displaying the zero cells in the chart but the bar chart works even though it has formula.
Can someone please help me with my situation as I would like to automate the chart using the line graph and at the same time keep the formulas in the cells?

Hello All,
I am using Excel 2007 and have a situation with the charting functionality.
For example - I am trying to set up automatic update chart update for Jan 08
– Dec 08 data i.e. user just enters data each month and the graph trend shows
up each month. I have done this a lot of times but seem to have a unique
situation with excel 07 this time when I am using the line chart type to show
the trend.
The date cells that have some kind of formulas used i.e. if function or
Iserror function etc. I tried to test the chart by entering data for January
it works fine with bar graph only displaying Jan 08 data and other months
zero but when I switch the chart type to line chart instead of just showing a
point for January 08 data it shows the Jan 08 data and other months as zero
i.e. graph line drops from the value to zero.
I tried to set the hidden empty cells as zero and gaps (Excel 07 option) but
it did not work. Next I removed the formulas i.e. the IF function and other
functions and manually entered the data……line chart worked fine i.e. did not
display the subsequent month’s data i.e. Feb 08 – Dec 08 which is all zero.
This to me is weird that once you remove the formulas the line chart works
fine by not displaying the zero cells in the chart but the bar chart works
even though it has formula.
Can someone please help me with my situation as I would like to automate the
chart using the line graph and at the same time keep the formulas in the
cells?

Hi!

As you can see from the screenshoot the actual values inside of the graph are not the ones I want. I want the values from date 2010->2011 like the X-axis says but it keeps showing the 2005-2006 values whenever I hoover above the line.
Feels like I've tried everything and I got no idea why it ´works this way, very strange. When I change the X-axis to example 2005->2011 the value will increase from 2005->2008. No matter what I do it always starts on 2005.

I got a macro that changes the X-axis of the graph, the min and max value so you can see different times. Still it stays on 2005 and this is a major problem. The main idea is to be able to change intervals to see trends but since the value is the same the entire team it crashes.

I need this to work :<
Any help greatly appriciated!
Thank you!

http://img571.imageshack.us/img571/3527/graphk.jpg

Uploaded with ImageShack.us

Leia

Hi All,

I'm trying to do a line chart showing two teams and their cumulative scores over the period of a game. I've attached a sample with mock data.

Does anyone know if it is possible to change the x-series of the charts to display custom time intervals like 0 min 1 min, 2 min, 3 min, 4 min, etc?

Currently the x-series only has labels for each specific time there was a change in value. I've tried to change the scale but the options that I want aren't there.

Any Ideas?

Brad

I use a bar graph to display actual data and a line graph to display Budget data. Now, for obvious reasons, I only want to show data until the current month. The problem is that the line graph shows 0 (zero) values (which are the result of a formula like IF[ (A1="FEB-02";B1;"") ]and the bar graph does not show 0 (zero) values.
I get the following situation in a graph:
------ Jan Feb Mar Apr May
Actual 5 6 8
Budget 6 5 5 0 0
Why does the line not show the same behaviour as the bar ? I do not want the line to show 0 values or "" as 0 (zero).
BTW. Options-Tools-Graph shows: "Plot empty cells as: Not Plotted (leave gaps)"'
Apparently this only works for the Bar-Graph.
What can I do or is this just a peculiar habit of Excel2000 ?

I use Excel graph function to plot the data. All the time I have the trouble
to resize the y-axis label as it will not show all the words I type in. For
example, I type " Flow rate, L/min" in the y-axis label form. It only show
"Flow rate, L" in the graph. I have talked to other persons. Surprisingly,
they told they also had the same trouble. I am wondering if Microsoft company
knows the issue.
Did any one here have the same trouble and finally how to fix the problem?

I'm using a basic stacked chart w/ five data series. How do I show *both*
data labels and data values? Excel seems to only allow me to select one or
the other to display at a time. How can I do what I intend?

This is probably a very simple issue, but I don't know how to word the search.

I have two issues with an excel graph to automate it.

My first problem is that I have to manually select the source data when the data changes inside my spreadsheet. I have 35 slots that represent a 5 week period. Because the first day of the month does not always start on the first day of the week, I have to allow the extra 5 slots in my template. I have the cells set to show blank when there is no data entered in certain cells. Therefore, only days that the machine is up gets put into the 35 cell table. When I do this, the blank cells show up as 0 on the graph and it skews the line. I need some solution that will allow me to tell the graph to ignore zeros.

The second issue is the title in my graph. I have a set title, but need it to pull "Month Year" and "c81" from the worksheet it is on. I cannot seem to get it to populate automatically in the label. I would like it to look like the following:

614 Machine Uptime Percentage
%Month Year%
MTD PCT (%c81%)

where the %name% is the automatically populated item. I don't necessarily have a problem with hiding a cell and linking the label to that cell inside the graph, but I need it to change those two items automatically.

Im certain that a resolution to both of these items exist and I am certain it is an easy thing that I will be kicking myself in the rear over once I find out the resolution, but I need to get this done and im tired of wasting time. I hope this makes sense. If you need me to post an excel file as an example, I will be more than happy to. Your help will be greatly appreciated.

Background:
My job requires an engine analysis, called a Short Term Engine Trend Monitoring Program (STETMP), to predict when the next malfunction occurs. This analysis is made for two aircraft explaining the 2 files.

The goal:
To create a line in a graph that shows the value of the Outside Air Temperature (OAT) for the number of entries given (if unclear refere to the excel sheet "PH-CGC STETMP.xlsx").

The problem:
The OAT line in the graph of "PH-CGN STETMP.xlsx" will not accept the same formula used in the graph of "PH-CGC STETMP.xlsx" (which does work) with some slight adjustments for proper references.

If more details are required feel free to ask. Note: the password for PH-CGC STETMP.xlsx is 8183 and the password for PH-CGN STETMP.xlsx is 8181.

Assistance is much appreciated since I do not know how to solve this puzzle.

Thank you in advance,
Viktor Knoben

PS: be sure to download the files due to invalid references!

*SOLVED*
The solution was to copy the files to another computer and to perform the exact same steps as before. I have absolutely no clue why it did not work on my laptop, desktop and work desktop but all that matters is that the problem is solved!

Hello everybody!
Does anybody knows how to solve this proble in Excel (2007). I have to draw two graph-lines with same color for one characteristic value α, all on one graph (like shown in picture one)!. For example, I want both graphs with α=10 (but different values of Xi/H) to have the same color (dark blue). When Im drawing second α=10 graph (lower one), I have to choose new data, and when I do this, new graph is shown but in new lighter color (picture 2). Maybe I could solve this problem by manually changing the color of lower graph to dark blue, but i dont know how to do it? I hope I made my self clear.

I use Excel graph function to plot the data. All the time I have the trouble
to resize the y-axis label as it will not show all the words I type in. For
example, I type " Flow rate, L/min" in the y-axis label form. It only show
"Flow rate, L" in the graph. I have talked to other persons. Surprisingly,
they told they also had the same trouble. I am wondering if Microsoft company
knows the issue.
Did any one here have the same trouble and finally how to fix the problem?

I am building a workbook that tracks all transactions of a business. The sheet essentially has three tables in it. The first is for each individual transaction in all its details, the second conditionally sums the daily totals of each transaction type, and the third sums the month. All the formulas in the individual transaction record portion are functioning perfectly, however, in the daily totals the cells are not updating to display the values, or in one case updates to display the wrong value. Calculations are set to automatic. If you look at each cell with the formula builder the 'result' shows the correct value every time, and if you click on the formula bar at the top then hit enter the correct value will be generated. I have tried replacing all the '=' with new '=', I have tried re-saving to a new file, copying everything to a new file etc... I am now at the end of my rope and can not figure out what is wrong...

Any help would be greatly appreciated
Working in Excel Mac:2008

How do you put two data sets in columns and two different data sets in lines all in one excel graph?

Thanks.

hi,
i have a graph with lets say 10 entries A1:A10
how can i show the value of the last point on the chart? i know how to manually do this but i was wondering if this could be done automatically so that if my range was shrunken to A1:A5, A5's value would show as opposed to A10s!

possible?

I am asking to the experts the following problem that I am unable to
solve.
I have the following worksheet:
Classes:_______Lecturer1(hours):________Lecturer 2(hours):
macro_______________20______________________30
micro_______________40______________________50
literat._____________0______________________20

I need to show with stack bars that lecturer 1 (first stack bar) has
20+40 hours and the label of any piece of the bar should have the name
of the classes. So the piece of the bar with height 20 should contain
the text "macro", the other piece of height 40 the text "micro", etc.

With Excel the latter can be obtained by showing the values of series.
Yet the chart shown contain also the labels of the series that have no
value in that column. Example: in the first stack Column on the top
there is also the text "literat." though there is any piece of
"literat." column in it.
How do I avoid (apart to cancel it manually) that the label "literat."
(or for the matter of any other class) appear in those columns that do
not contemplate hours of that class?
Thanks
AR

I'm creating a jpg from a comma seperated input file.
The file is in the style

A,10,20
B,30,50
C1,21,40
C2,35,70
E,36,50

So has three values and is alphabetically listed with the first.

I'm creating the Excel graph with the following script

=================================================
DIM x(100)
DIM y(100)
DIM z(100)

vDate=Date()
LastMonth=DateAdd("m",-1,vDate)
vYear=Year(LastMonth)
vMonth1=Month(LastMonth)
vMonth=MonthName(vMonth1)
If vMonth10 then
splitline=split(vline,",")
x(linecount)=splitline(0)
y(linecount)=splitline(1)
z(linecount)=splitline(2)
End If
WEnd

inputFILE.Close
Set inputFILE=Nothing
Set oFS=Nothing

set loChartSpace = WScript.CreateObject("OWC10.ChartSpace")
set oConst = loChartSpace.Constants
set loGraph = loChartSpace.Charts.Add()
loGraph.Type = 3

loGraph.HasLegend = True
loGraph.PlotArea.Interior.Color = "azure"

loChartSpace.HasChartSpaceTitle = True
loChartSpace.ChartSpaceTitle.Caption = "Values - "& vMonth & ", "&vYear
loChartSpace.ChartSpaceTitle.Font.Bold = True

Set objAxis = loGraph.Axes(oConst.chAxisPositionBottom)

'Axis Properties
With objAxis
..HasTitle = True
..Scaling.Maximum=100
..Title.Caption = "Percent"
..Font.Size = 6
End With

Set objAxis = loGraph.Axes(oConst.chAxisPositionLeft)

'Axis Properties
With objAxis
..HasTitle = True
'.Scaling.Maximum=100
..Title.Caption = "Values"
..Font.Size = 8
End With

loGraph.SeriesCollection.Add()
loGraph.SeriesCollection(0).Caption = "In"
loGraph.SeriesCollection(0).Interior.Color = "#66ccff"
loGraph.SeriesCollection(0).SetData oConst.chDimCategories,
oConst.chDataLiteral, x
loGraph.SeriesCollection(0).SetData oConst.chDimValues,
oConst.chDataLiteral, y

loGraph.SeriesCollection.Add()
loGraph.SeriesCollection(1).Caption = "Out"
loGraph.SeriesCollection(1).Interior.Color = "#000099"
loGraph.SeriesCollection(1).SetData oConst.chDimValues,
oConst.chDataLiteral, z

lcFile = "D:rankgraphs"&vYear&vMonth1&".jpg"

loChartSpace.ExportPicture lcFile,"jpg",800,600
================================================== =======

Most of which has been found on the internet (so if you see some of your own
code in there - thanks!!!!!!!)

The thing is I'm setting loGraph.Type = 3 which is sideways columns.
The problem I've got is that the values in the first column of the csv
(alphabetical) are displayed in reverse (top to bottom) on the graph.
So the graph show in the left column :
E
C2
C1
B
A

It seems to be OK if I choose loGraph.Type = 0 (columns going up) with the
bottom axis showing A,B,C1,C2,E

Is there any way I can flip the data simply so when I've got loGraph.Type =
3 the left axis is alphabetically downwards?

Many Thanks

Hello,
I have a 3D graph in access (but it's imported from excel).
The Y Axis (the horizontal bottom axis) represents years. I each and every
year to appear on the screen under the axis. So I asked the computer to show
the values of the Y axis. Usually everything is OK, and the computer shows
all the values, but sometimes (when I have many points in that Axis) the
computer writes down only every second value. Is there a way I can force the
computer to always show all the values?
thank you
--
dshemesh


No luck finding an answer? You could always try Google.